Chrome - 40+ seconds to load Amazon Turk

78Btjtrp

New Member
Joined
Apr 6, 2016
Messages
16
Reaction score
5
Points
253
Age
47
Gender
Male
Ever since upgrading to Windows 10 (I did a completely fresh install on a formatted SSD), it takes over 40 seconds to completely load Amazon Turk pages (Your Account, etc), including the Welcome page. Using latest version of Chrome. The page will appear to load, but the little "loading" circle keeps spinning, and no scripts will run until the circle stops and the page is completely finished loading.

Originally I thought it must be related to scripts, but I uninstalled all scripts and completely removed Tapermonkey, and got the same result. Other websites load maybe a little slower than they used to under Windows 7, but only by a second or two at most.

Anyone familiar with this?
 

mordea

Master of a Couple Things
Contributor
Joined
Jan 22, 2016
Messages
821
Reaction score
2,592
Points
568
Location
Ohio
Gender
Male
You can attempt to see what may be loading slowly by using the developer console which can be found on the settings menu under More Tools. or by pressing ctrl+shift+i. Click on the Network tab and then reload your page. You can see how long each item the page is requesting will take to load.
 

78Btjtrp

New Member
Joined
Apr 6, 2016
Messages
16
Reaction score
5
Points
253
Age
47
Gender
Male
 
Last edited:

mordea

Master of a Couple Things
Contributor
Joined
Jan 22, 2016
Messages
821
Reaction score
2,592
Points
568
Location
Ohio
Gender
Male
I'm fairly certain omtrdc.net is Adobe analytics tracking. Are you using an ad blocker such as Ublock Origin? If not, that might be of some help.
 

78Btjtrp

New Member
Joined
Apr 6, 2016
Messages
16
Reaction score
5
Points
253
Age
47
Gender
Male
I'm fairly certain omtrdc.net is Adobe analytics tracking. Are you using an ad blocker such as Ublock Origin? If not, that might be of some help.
Not using any adblockers. I appreciate the suggestion, but I'd rather not go that route. I'm just wondering what might cause the issue, I can't be the only one having this problem.

If you are also on Windows 10, would you be willing to disable your adblocker for a test just to see if Chrome tries to access this "omtrdc.net" entry? When I try to get to the MTurk Welcome screen, the developer console lists 29 requests, looks like this one is entry 22 for me anyway.