mturk HITs page loads very slowly

kkyn

New Member
Joined
Jul 26, 2016
Messages
4
Reaction score
6
Points
3
Age
31
Gender
Male
Hi everyone, this is my first post here. I hope I am posting this in the correct section.

The problem that I have is that in the mornings during the work week (MON - FRI), the HITs page on mturk loads very slowly; most of the time, it wouldn't load completely and will display the following message:

"Your request was not completed successfully.

Please try it again. If you continue to receive this message, please try your request again later."

This will persist from the morning until around 3 pm in the afternoon. Since I can't access the HITs page consistently during the mornings, it has made the turking experience very frustrating and inefficient as I often can't browse the list of HITs available and HITscraper needs that page to scrape the available HITs.

I have tried the following, but none of them fixes the problem:

Logging out and logging back into my account
Accessing the mTurk platorm and logging in using the incognito mode
Switching to another browser(Chrome, Firefox, Internet Explorer, Edge - all using the latest versions)
Clearing cache, clearing cookies
Using another internet connection, like a library's connection or my cellular connection
Using another computer
Disabling all extentions in my browsers
Disabling all scripts

I have also tried contacting mTurk customer service, but they gave me the usual response(nothing is wrong on their end) and it was not helpful.

I want to note that this only happens when I am logged in. When I am logged out, the HITs page loads very quickly. On the weekends and during the evenings, the HITs page loads quickly. I thought that this might be an issue related to too many users using the mTurk platform, but it seems unlikely as this has happened every weekday for the past two weeks and other users of this forum do not seem to have expereinced these difficulties.

Has anyone else had this experience? Does anyone know why this is happening?

Thank you for taking the time to read the post.
 
  • Like
Reactions: DONTDOIT

MerryLou

unpalatable
Contributor
Crowd Pleaser
Sole Survivor
Joined
Jan 12, 2016
Messages
11,257
Reaction score
20,501
Points
1,688
Gender
Female
I'm so sorry I don't have any info, and this totally sucks :thumbdown:

I believe DONTDOIT @DONTDOIT is having similar issues, maybe ya'll can compare notes so to speak?
 
  • Like
Reactions: DONTDOIT

CloudNine

Well-Known Member
Joined
Jan 12, 2016
Messages
1,583
Reaction score
4,137
Points
513
Gender
Male
Hi everyone, this is my first post here. I hope I am posting this in the correct section.

The problem that I have is that in the mornings during the work week (MON - FRI), the HITs page on mturk loads very slowly; most of the time, it wouldn't load completely and will display the following message:

"Your request was not completed successfully.

Please try it again. If you continue to receive this message, please try your request again later."

This will persist from the morning until around 3 pm in the afternoon. Since I can't access the HITs page consistently during the mornings, it has made the turking experience very frustrating and inefficient as I often can't browse the list of HITs available and HITscraper needs that page to scrape the available HITs.

I have tried the following, but none of them fixes the problem:

Logging out and logging back into my account
Accessing the mTurk platorm and logging in using the incognito mode
Switching to another browser(Chrome, Firefox, Internet Explorer, Edge - all using the latest versions)
Clearing cache, clearing cookies
Using another internet connection, like a library's connection or my cellular connection
Using another computer
Disabling all extentions in my browsers
Disabling all scripts

I have also tried contacting mTurk customer service, but they gave me the usual response(nothing is wrong on their end) and it was not helpful.

I want to note that this only happens when I am logged in. When I am logged out, the HITs page loads very quickly. On the weekends and during the evenings, the HITs page loads quickly. I thought that this might be an issue related to too many users using the mTurk platform, but it seems unlikely as this has happened every weekday for the past two weeks and other users of this forum do not seem to have expereinced these difficulties.

Has anyone else had this experience? Does anyone know why this is happening?

Thank you for taking the time to read the post.
This is happening to me as well and i've tried everything you did. It's fast in the morning and during the evenings but gets extremely slow and choppy during the afternoons. Which sucks because that's when all the work drops. :(
 
  • Like
Reactions: DONTDOIT

Johnnyrs

Active Member
Contributor
Crowd Pleaser
Joined
Jan 12, 2016
Messages
500
Reaction score
1,549
Points
668
Age
49
Location
Whittier, California
Gender
Male
Check how many items displayed per page. 10 or 20 is fast but 50 or 100 will go very slow. Once you change the number it remembers it for any time you search. There may be a script that defaults to a higher number always so that's something to check as well.
 

CloudNine

Well-Known Member
Joined
Jan 12, 2016
Messages
1,583
Reaction score
4,137
Points
513
Gender
Male
Hmm, is anyone else having this problem? Or has found a solution?
 
  • Like
Reactions: DONTDOIT

DONTDOIT

Custom Title:
Contributor
Joined
Jan 12, 2016
Messages
203
Reaction score
461
Points
338
Gender
Male
Hi everyone, this is my first post here. I hope I am posting this in the correct section.

The problem that I have is that in the mornings during the work week (MON - FRI), the HITs page on mturk loads very slowly; most of the time, it wouldn't load completely and will display the following message:

"Your request was not completed successfully.

Please try it again. If you continue to receive this message, please try your request again later."

This will persist from the morning until around 3 pm in the afternoon. Since I can't access the HITs page consistently during the mornings, it has made the turking experience very frustrating and inefficient as I often can't browse the list of HITs available and HITscraper needs that page to scrape the available HITs.

I have tried the following, but none of them fixes the problem:

Logging out and logging back into my account
Accessing the mTurk platorm and logging in using the incognito mode
Switching to another browser(Chrome, Firefox, Internet Explorer, Edge - all using the latest versions)
Clearing cache, clearing cookies
Using another internet connection, like a library's connection or my cellular connection
Using another computer
Disabling all extentions in my browsers
Disabling all scripts

I have also tried contacting mTurk customer service, but they gave me the usual response(nothing is wrong on their end) and it was not helpful.

I want to note that this only happens when I am logged in. When I am logged out, the HITs page loads very quickly. On the weekends and during the evenings, the HITs page loads quickly. I thought that this might be an issue related to too many users using the mTurk platform, but it seems unlikely as this has happened every weekday for the past two weeks and other users of this forum do not seem to have expereinced these difficulties.

Has anyone else had this experience? Does anyone know why this is happening?

Thank you for taking the time to read the post.
Hmm, is anyone else having this problem? Or has found a solution?
I was on vacation all last week and hoped it would magically go away but it didn't. :thumbdown:. What sucks is that it's only affecting a few of us so the chances of it getting fixed are slim. No idea what to do beyond daily e-mails complaining about the issue.
 
  • Like
Reactions: CloudNine

CloudNine

Well-Known Member
Joined
Jan 12, 2016
Messages
1,583
Reaction score
4,137
Points
513
Gender
Male
I was on vacation all last week and hoped it would magically go away but it didn't. :thumbdown:. What sucks is that it's only affecting a few of us so the chances of it getting fixed are slim. No idea what to do beyond daily e-mails complaining about the issue.
This is crazy. There has to be a solution. Is it the same time for you too? Around 12pm - 4pm ET? I got an email back from them but they just said to clear cookies and caches which has absolutely nothing to do with the problem..
 

Matilda Jones

Grey Ghost
Contributor
Joined
Jan 24, 2016
Messages
4,608
Reaction score
6,757
Points
788
Gender
Female
Both of my scraper windows just went totally blank and I can't accept anything. I am so over this.
 

DONTDOIT

Custom Title:
Contributor
Joined
Jan 12, 2016
Messages
203
Reaction score
461
Points
338
Gender
Male
This is crazy. There has to be a solution. Is it the same time for you too? Around 12pm - 4pm ET? I got an email back from them but they just said to clear cookies and caches which has absolutely nothing to do with the problem..
Yup, always around 12pm -4pm. Weekends appear to be working fine though.
 
  • Like
Reactions: CloudNine

CloudNine

Well-Known Member
Joined
Jan 12, 2016
Messages
1,583
Reaction score
4,137
Points
513
Gender
Male
Today is worse for me than it has been.
Yeah, mine's still not working at all. Can't click on the HITS tab on mturk and hitscraper is broke because of this. Usually it starts working again around this time. -_-
 

Matilda Jones

Grey Ghost
Contributor
Joined
Jan 24, 2016
Messages
4,608
Reaction score
6,757
Points
788
Gender
Female
It's weird because I can work from a batch fine, it's like if I try to search mturk at all it just craps itself.
 
  • Like
Reactions: DONTDOIT

turks24

New Member
Joined
Aug 9, 2016
Messages
15
Reaction score
10
Points
3
Age
97
Gender
Male
A few of us on MTG are having the same problem. Melting Glacier and I have had this issue intermittently going back about 3 weeks. It almost always occurs around 3 pm est.

I've tried about 20 different combinations of browsers (Chrome, Safari, FF) devices (laptop, iPad, phone) and connections (my regular internet, vpn, personal phone hotspot, work phone hotspot and usb mobile modem). It's 100% not anything on my end.

I've also discovered that it seems to be something with our accounts. Try to log out and open the hit tab. It works perfectly for me. If I log back in the page won't load.
 
Last edited:

CloudNine

Well-Known Member
Joined
Jan 12, 2016
Messages
1,583
Reaction score
4,137
Points
513
Gender
Male
A few of us on MTG are having the same problem. Melting Glacier and I have had this issue intermittently going back about 3 weeks. It almost always occurs around 3 pm est.

I've tried about 20 different combinations of browsers (Chrome, Safari, FF) devices (laptop, iPad, phone) and connections (my regular internet, vpn, personal phone hotspot, work phone hotspot and usb mobile modem). It's 100% not anything on my end.

I've also discovered that it seems to be something with our accounts. Try to log out and open the hit tab. It works perfectly for me. If I log back in the page won't load.
Yeah, it's definitely our accounts. That's the tough part.. i don't know if there's anything we can do but wait it out and hope it fixes itself. Sigh. I've emailed them multiple times but just got the same answers.
 

turks24

New Member
Joined
Aug 9, 2016
Messages
15
Reaction score
10
Points
3
Age
97
Gender
Male
Yeah, it's definitely our accounts. That's the tough part.. i don't know if there's anything we can do but wait it out and hope it fixes itself. Sigh. I've emailed them multiple times but just got the same answers.
I emailed them just now and said that I've tried every imaginable way to rule out a problem on my end
 

turks24

New Member
Joined
Aug 9, 2016
Messages
15
Reaction score
10
Points
3
Age
97
Gender
Male
I emailed them just now and said that I've tried every imaginable way to rule out a problem on my end
Thank you for reaching out to us, this is Toefiqh from Amazon Mechanical Turk.

I've checked the Mechanical Turk Service Health Dashboard and see that the Amazon Mechanical Turk Worker service platform is operating normally.

Mechanical Turk is designed to work in the newest versions of both Firefox and Internet Explorer. While I'm unable to determine what is causing the error you received, if you are still encountering an issue using the latest versions of these browsers you may want to try the following.

-- Clear your cache. Sometimes a full cache can slow down your web browsing. Instructions for clearing your cache should be available in your browser's Help menu.
-- Clear your cookies. The problem may be caused by one of our servers, or by corrupted cookie files on your browser. Instructions for clearing your cookies should be available in your browser's Help menu.
 

CloudNine

Well-Known Member
Joined
Jan 12, 2016
Messages
1,583
Reaction score
4,137
Points
513
Gender
Male
^ I usually get the same response. I emailed them again last night and got this.

Hello,

I'm sorry for the continued troubles you are having with using the Mechanical Turk site.

I've forwarded this to our developers to investigate and work toward a resolution.

Thanks for your patience while we look into this. If you have any further questions or concerns, please let us know.


Doesn't really mean much, but it's a different response from the usual "clear cookies and cahce."
 
Last edited:

Matilda Jones

Grey Ghost
Contributor
Joined
Jan 24, 2016
Messages
4,608
Reaction score
6,757
Points
788
Gender
Female
I just emailed support. I expect it to go nowhere but if this doesn't improve I'm not going to be able to turk anymore. :(

Edit: It's now happening when I am logged out too. Hmm.
 
Last edited:
  • Like
Reactions: CloudNine